Author Topic: Windows 2008 Xen/HVM "Folder Access Denied" permission issue  (Read 34201 times)

forexverified

  • Guest
Windows 2008 Xen/HVM "Folder Access Denied" permission issue
« on: December 10, 2012, 03:06:25 PM »
Hello,

I have some new Windows 2008 VPS's on the Xen/HVM system.  I'm logging in with RDP.  The servers have only one user account (Administrator) with administrator privileges.   UAC is turned off.

I'm having trouble deleting folders.  It doesn't matter the location (a folder on the desktop, a folder on the C: drive, or in Program Files, etc.)   It doesn't matter how long the folder has existed or what it contains.  When I try to delete one, I get the error:

Folder Access Denied
You need permission to perform this action
You require permission from Administrators to make changes to this folder
    [ Try Again ]    [ Cancel ]


If I click "Try Again" periodically, it will eventually delete the folder successfully.  It normally takes 1-2 minutes.

It's definitely not a permission issue because I have admin privileges and it does delete successfully after a minute or so.  But the error insists on popping up for roughly 60 seconds from the moment I first try to delete a folder.

Any ideas?

Scott Wang

« Last Edit: December 10, 2012, 03:08:03 PM by forexverified »

Offline Chris

  • Solar VTG Staff
  • Jr. Member
  • *****
  • Posts: 90
    • View Profile
Re: Windows 2008 Xen/HVM "Folder Access Denied" permission issue
« Reply #1 on: December 18, 2012, 01:44:20 PM »
Hi Scott,
Sorry for the delay in replying to this, as mentioned in the support ticket we've suggested the following:
1. Make sure that you have the latest Windows Updates installed on your VM.
2. Verify the list of installed applications to ensure that there are no memory resident apps that would perform any actions in the back-end when you interact with a folder. This might also involve AV solutions for eg, but it's more of a recommendation that you should check, as we've not seen this before and we're not able to reproduce it in a clean test environment.

If you have any other further comments please reply to the existing support ticket and we'll assist you from there.
Thank you!
Chris Valean :: Solar VPS LLC
www.solarvps.com : support@solarvps.com
US & UK Windows & Linux Virtual Services : Hosted Exchange & Sharepoint

forexverified

  • Guest
Re: Windows 2008 Xen/HVM "Folder Access Denied" permission issue
« Reply #2 on: December 18, 2012, 02:27:37 PM »
Just updating this thread for the benefit of anyone reading:

Well just as expected, when I picked a VPS and tried to reproduce the issue on purpose, the folders deleted just fine. In fact, I just spot-tested it on 4 different servers and they all deleted folders properly. I'll start to pay closer attention to the details surrounding the issue now. So far I can say:

- It happens on a brand new setup even before any software is installed

- It also happens after all the Windows updates are installed

- It has happened on every one of the 12 VPS's I've set up so far (plus the 2 that I set up for a buddy today)

- It usually happens on folders regardless of their content, but I have also had "File Access Denied" error when deleting text files (same symptom: after attempting to delete the file, wait 60 seconds, hit Try Again, and then it works), but not nearly as often. It's normally folders.

- I'm not running any software (like antivirus) that would scan/do actions on the folders

It was happening all the time, with almost every folder I tried to delete.. but if I can't re-produce the issue now, there's obviously nothing you can do. I'll just keep an eye on it and update the ticket if I have any concrete way of reproducing the issue.

If an issue is found/resolved I'll update the thread again too, but apparently I need to collect more data first.  :)

Scott Wang

forexverified

  • Guest
Re: Windows 2008 Xen/HVM "Folder Access Denied" permission issue
« Reply #3 on: May 08, 2013, 03:42:55 PM »
[[[[[ !!!!! FIXED FIXED FIXED FIXED !!!!! ]]]]]]

It was my fault.  I'm a fanatic when it comes to optimizing a VPS to maximize resources so I can reduce the Windows overhead as much as absolutely possible.

So I have a list of about 10-15 Windows services that I automatically disable by default because they're not needed for my purposes (Forex platforms).  I disable these same services on every VPS I've ever used, including Windows XP / 2003 / 2008 and 2012, on a variety of virtualization technologies including Virtuozzo, Xen, ESX, and Hyper-V.

Well, it turns out that one of these services is needed on these SolarVPS's.  It's the "Application Experience" service.  It's supposed to be a service related to Windows checking software for compatibility but since I know all our software is compatible, I always disabled that service and never had an issue doing so.

So I re-enabled that service on my servers and sure enough, now I can delete files and update my software without any issues.   Crazy....!   I'm happy to have found a solution.

-Scott